I am building a custom connector for a SaaS platform where you provide a list of “projects,” and it will then discover datasets (streams) within those projects. Each dataset has a name (e.g. “My Project”) and an ID (e.g., UUID). I want the name returned in the catalog to be a human-readable name, but the APIs all operate on IDs.
I don’t understand whether there is a place I can stash the return ID in the catalog so that it’s available in my
read() method. Without this, I have to go and re-fetch all the datasets again to try and match the name, to get the ID to then pass back. I don’t want to change the name to the ID (as then it’s no longer readable). I can do the “look through every named dataset,” but it seems unnecessary since I have the information in hand when I created the catalog in
discover(). There is a
namespace option in the
AirbyteStream class, but it says all streams returned from a source should share the same namespace.
Is there any connector-specific configuration storage within the catalog where I can keep this information? Or is the only option to just re-scan everything to do the name → id mapping?
Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:
- It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
- Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
- Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
- We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.
Thank you for your time and attention.
The Community Assistance Team