Hubspot connector not importing Associations correctly

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Ubuntu (Google VM)
  • Memory / Disk: 8GB / 40GB
  • Deployment: Docker
  • Airbyte Version: 0.39.35
  • Source name/version: Hubspot
  • Destination name/version: BigQuery 1.1.11
  • Step:
  • Description: I recently noticed that when used Incremental modes in the BigQuery connector i do not get any information regarding associations. I.e. My deals table has no records on companies, contacts or line_items. While if I use Full Overwrite mode I can get the associated companies and contacts (while still no Line Items) correctly. I wonder if this behaviour is expected due to the limitations of the Hubspot API or if this is an actual issue.

Even if there were a pure associations columns with the untreated JSON it would be better, since associations are a vital part of data analysis in Hubspot.

Hello @gguerra, could you please provide any logs you might be getting so I can see if there are error messages there? Thank you!

I’d like to report the same behavior. HS → Postgres and I’m doing incremental. Following columns come up empty:

  • Deals (table) → contacts, companies, dealstage, line_item (I don’t have data for this, but I assume it is a similar case).
  • Contacts (table) → companies.

I have not tried full overwrite yet (which is suppose to work as the OP stated).

Hello, @skulltima

I found this issue on GitHub: HubSpot deals stream does not sync associations when sync mode is Incremental + Dedupe · Issue #14390 · airbytehq/airbyte · GitHub that provides the answer to this problem.

Whereas this is not actually a solution, at least it provides an understanding of the current situation and possible workarrounds.

awesome. thanks for the reply. i will comment and vote to that issue as well. hopefully it will get resolved soon!

1 Like