Issue with Airbyte worker after updating to 0.50.44


Enum constant error in Airbyte worker after updating to version 0.50.44


Hi folks - seeing an issue with airbyte worker after updating to 0.50.44:

Message: No enum constant
Path Taken: new ApplicationInitializer() –> ApplicationInitializer.checkConnectionActivities –> List.checkConnectionActivities([CheckConnectionActivity checkConnectionActivity]) –> new CheckConnectionActivityImpl(WorkerConfigsProvider workerConfigsProvider,ProcessFactory processFactory,SecretsRepositoryReader secretsRepositoryReader,Path workspaceRoot,WorkerEnvironment workerEnvironment,[LogConfigs logConfigs],AirbyteApiClient airbyteApiClient,String airbyteVersion,AirbyteMessageSerDeProvider serDeProvider,AirbyteProtocolVersionedMigratorFactory migratorFactory,FeatureFlags featureFlags,FeatureFlagClient featureFlagClient,GsonPksExtractor gsonPksExtractor,WorkloadApi workloadApi,WorkloadIdGenerator workloadIdGenerator,JobOutputDocStore jobOutputDocStore) –> new LogConfigs([Optional storageConfigs])
at io.micronaut.context.DefaultBeanContext.resolveByBeanFactory( ~[micronaut-inject-3.10.1.jar:3.10.1]
at io.micronaut.context.DefaultBeanContext.doCreateBean( ~[micronaut-inject-3.10.1.jar:3.10.1]
at io.micronaut.context.DefaultBeanContext.doCreateBean( ~[micronaut-inject-3.10.1.jar:3.10.1]
at io.micronaut.context.DefaultBeanContext.createRegistration( ~[micronaut-inject-3.10.1.jar:3.10.1]
at io.micronaut.context.SingletonScope.getOrCreate( ~[micronaut-inject-3.10.1.jar:3.10.1]
at io.micronaut.context.DefaultBeanContext.findOrCreateSingletonBeanRegistration( ~[micronaut-inject-3.10.1.jar:3.10.1]
at io.micronaut.context.DefaultBeanContext.resolveBeanRegistration( ~[micronaut-inject-3.10.1.jar:3.10.1]
at io.micronaut.context.DefaultBeanContext.resolveBeanRegistration( ~[micronaut-inject-3.10.1.jar:3.10.1]
at io.micronaut.context.DefaultBeanContext.findBean( ~[micronaut-inject-3.10.1.jar:3.10.1]
at io.micronaut.context.AbstractBeanResolutionContext.findBean( ~[micronaut-inject-3.10.1.jar:3.10.1]
at io.micronaut.context.AbstractInitializableBeanDefinition.resolveOptionalBean( ~[micronaut-inject-3.10.1.jar:3.10.1]

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want to access the original thread.

Join the conversation on Slack

["airbyte-worker", "update", "enum-constant-error", "version-0.50.44"]

<@U06FUELHQMN> please use threads.

Apologies <@U01MMSDJGC9>!

seems like the enum is actually there - and I’ve tried a good few different combinations (local, s3, minio etc for the WORKER_LOGS_STORAGE_TYPE and WORKER_STATE_STORAGE_TYPE) to no avail.

Message: No enum constant for example is so odd - I can see the enum there, and the environment variable is set. Any ideas?

From what version did you upgrade from <@U06FUELHQMN>?

My env file and docker-compose yml are both the same as the ones currently in main in airbyte-platform

I cleared down all the images, containers and volumes and restarted, but same issue. I’m using an external Postgres DB for the airbyte DB - so there may be some data lying around in there related to the upgrade from 0.44.1

Did you retrieve the flags.yaml file as well?

I’m also experiencing this any updates?

<@U06ACAECS2G> and <@U06FUELHQMN> are you using external S3 logs in Helm or Docker?

Nope, I was just using local. I managed to resolve this - turned out there was actually a formatting issue in the .env file - there were some characters that weren’t showing up in my editor causing weirdness. It’s working now

• what does your .env file look like? If it’s the same issue as mine, check that your WORKER_LOGS_STORAGE_TYPE and WORKER_STATE_STORAGE_TYPE env var values don’t have any characters at the end
• What version of airbyte are you running
• On the flags thing - I had to update the path to flags to be an absolute path

Hi <@U06FUELHQMN>, I upgraded to the latest release tag 0.50.47 and that solved the problem Message: No enum constant in my case.

Hello Nithin and Martin, please take a look in maybe there is some help there

yep, it’s there too - alongside the docker-compose.yml and .env

oh wait - does it have to be inside the configs folder?


2024-01-24 14:17:31 INFO i.a.f.ConfigFileClient(&lt;init&gt;):105 - path /flags does not exist, will return default flag values

from the server logs

updated the path but the worker is still throwing the error about the missing enum unfortunately