Missing Column When Sync With Zuora

  • Is this your first time deploying Airbyte?: Yes
  • OS Version / Instance: Linux (Amazon)
  • Memory / Disk: you can use something like 16Gb / 8 Gb
  • Deployment: Docker
  • Airbyte Version: 0.40.10
  • Source name/version: Zuora alpha 0.1.3
  • Destination name/version: Snowflake
  • Step: The issue is happening during sync
  • Description:

Airbyte Zuora connector doesn’t fetch CancelReason column of the Subscription data object. I refreshed the source schema but it didn’t work.

Hey @murat-cetinkaya,

Can you point where the CancelReason field is in the Subscription data object? I tried looking for it in Zuora’s API docs but couldn’t find it.

The Zuora connector dynamically creates the schema for the data objects so I’m not sure why that field is not being fetched.

I checked the source table and couldn’t see the column but it’s an attribute of Subscription data source on the Zuora application. It’s probably a result of a join with another table. We can check this item as solved. Thank you very much for your quick return @sajarin :+1:t3:

Just for the record. The cancelreason attribute of Subscriptions object comes when I refresh the source schema.

Thanks for the followup @murat. I wonder why it didn’t work before when you tried refreshing the source schema. Glad to hear it’s working know though.