Postgres source tables have no incremental option

  • Is this your first time deploying Airbyte?: Yes
  • OS Version / Instance: Amazon Linux
  • Memory / Disk: t3a.2xlarge
  • Deployment: Docker
  • Airbyte Version: 0.40.7
  • Source name/version: source-postgres 1.0.10
  • Destination name/version: destination-snowflake 0.4.36
  • Step: The issue is happening creating the connection and selecting how to replicate
  • Description: When configuring the replication between postgres and snowflake only a few of the tables have an option for incremental sync.

Screen Shot 2022-09-22 at 7.16.46 PM

Check the database table directly. The tables have valid cursor and primary keys.

order_pkey" PRIMARY KEY, btree (id
updated_at | timestamp without time zone | | | | plain

checking the logs i see it sees pkeys and but no cursor values.


I understand with postgres you have to select it, and it will not auto populate but the ui doesn’t have the option and does not show any pkey either…

A handful of tables have the option while most do not.

Any help would be much appreciated!

I’ve tried setting this up on multiple other databases. Postgres: 12.8/13.7/13.4/14.3. And it works as expected… The issue seems specific to most of the tables in this database but I’m not sure what…

Digging into it some more i found a few tables that are supported in the db without issues… trying to find out what is different between the tables that have the incremental option and the ones that don’t.

Adding 2 config outputs for a tables that has the incremental option and one that does not in the db.

test_a.txt (3.6 KB)
test_b.txt (2.0 KB)

test_a → only full refresh options
test_b → has both options.
Logs when trying to load the schema and set replication for each stream…

Both of these tables have primary keys and valid cursors… so again not sure why one can have incremental and the other can not.

After this further digging my questions is, is there some requirement for incremental replication other than having a pkey and valid cursor for it to appear as an option in the UI. Trying to understand what allows one table to replicate incrementally vs the other…

Another Edit:

DB Sources: only show a table can sync incrementally if at least one column can be used as a cursor field

So it seems this is probably the reason i don’t see them, but then i’m still trying to figure out why it does not think there is a valid field, when based on the above configs it seems, there are valid fields?

Last Edit: yes it seems to be an option now and working.



Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

1 Like

Same problem here. Looking forward to ideas from the community or airbyte staff.

I see Incremental - Append on my end, but no Incremental - Deduped History. Looking into this!

Same issue on my side

The issues seem to be resolved on the latest of the postgres source. Seems to have been related to nullable columns

Upgrading to 1.0.11 or downgrading to 1.0.2 has solved the issue for me.

@robertput thanks for the input!