Postgres sync getting stuck at a specific point during sync

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Amazon Linux 2 / t3.large EC2 instance
  • Memory / Disk: 8Gb memory / 30 Gb EBS volume
  • Deployment: Docker on EC2
  • Airbyte Version: v0.40.8
  • Source name/version: Postgres / 1.10.0
  • Destination name/version: S3 / 0.3.15
  • Step: The issue is happening during sync
  • Description: Postgres sync is getting stuck at a specific point every time we try to run it – it looks like it may be a memory issue; however, the amount of memory used is way below the available memory on the EC2 instance.

Note: I’m running Airbyte on the latest version (0.40.8) with the latest version for the source-postgres connector (1.10.0)

I attempted to reset our Postgres sync to perform a full refresh but the sync is getting stuck after reading ~93K records (~315 MB). I tried cancelling and retrying the sync a few times but each time it is getting stuck at the same point (93K records / 315 MB).

I then tried running the sync for one table (the table has ~130K records in the source) and the sync was still getting stuck at a specific point (in this case 83K records / 299 MB). Again, I tried cancelling and retrying the syncs but it consistently got stuck at the same point (83K records / 299 MB).

I also tried running the sync for a smaller table (~24 MB of data) and that sync was able to completely successfully which is why I believe this may be a memory issue; however, I find this behavior quite strange as there is 8Gb of RAM available on the instance and no other syncs are running at the same time yet the sync is still getting stuck trying to ingest a relatively small amount of data relative to the available memory on the instance.

docker stats at the time the sync gets stuck:

output of running $ free -m at the time the sync gets stuck:

connection logs:
07281f2b_a2c0_40e7_8707_0af7899916b7_logs_212_txt.txt (305.0 KB)

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Can you try to replicate to another destination to isolate the issue? Not sure if the problem is happening in destination or source right now.

I’ll try running the sync w/ Redshift as the destination but I suspect the issue is w/ the source as we have other connections (Mixpanel, Salesforce) that write to the same destination and they’ve been running fine w/o any issues.