Error: Failure Origin: replication, Message: Something went wrong during replication

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Ubuntu / EC2
  • Memory / Disk: 4 gb / 20 gb
  • Deployment: Docker
  • Airbyte Version: 0.44.5
  • Source name/version: Postgres latest
  • Destination name/version: Postgres latest
  • Step: The issue is happening during sync
  • Description: Need to transfer around 8 gb from pg to pg databases. Every time after sometime, sync fails with error mentioned in title. I checked the logs at /var/lib/docker/volumes/airbyte_workspace/_data/26/0/logs.log where 26 is job-id and 0 is the attempt-1 number. I could not find any error.
    The last lines in logs are :
2023-05-24 19:55:56 ^[[43mdestination^[[0m > INFO i.a.i.b.FailureTrackingAirbyteMessageConsumer(close):80 Airbyte message consumer: succeeded.

2023-05-24 19:55:56 ^[[43mdestination^[[0m > INFO i.a.i.d.b.BufferedStreamConsumer(close):257 executing on success close procedure.

2023-05-24 19:55:56 ^[[43mdestination^[[0m > INFO i.a.i.d.r.InMemoryRecordBufferingStrategy(flushAll):85 Flushing finder_results: 182 records (6 MB)

and then suddenly sync failed.

Im middle, there is one line as

2023-05-24 19:55:50 ^[[44msource^[[0m > /airbyte/ line 26:     8 Killed                  /airbyte/bin/"$APPLICATION" "$@"

I tried around SEVEN times, almost same behaviour each time.

Please help !
Thanks in advance!

I tried with new connection on smaller pg source having just 300 mb, There it worked fine.

It fails after 8 gb of data transfer