Postgres to Postgres suddenly failing

  • Is this your first time deploying Airbyte?: No
  • Deployment: Are you using Docker or Kubernetes deployment? Kubernetes
  • Airbyte Version: What version are you using now? v0.39.42-alpha
  • Source name/version: Postgres 1.0.3
  • Destination name/version: Postgres 0.3.22
  • Step: The issue is happening during sync, creating the connection or a new source? During Sync
  • Description: Remove this with the description of your problem. I recently upgraded Airbyte and all the connectors (postgres source and dest), and the normalization seems to now fail. I’ve rolled back to connectors and Airbyte versions that worked, but that still caused same error.

Log is attached!
logs-1206 (1).txt (98.1 KB)

Can you check the Connector Settings? Maybe after upgrading from an old version some configuration was changed and it broke the connection. In this case:

2022-08-23 15:22:05 e[43mdestinatione[0m > 2022-08-23 15:22:01 e[1;31mERRORe[m i.a.i.b.AirbyteExceptionHandler(uncaughtException):26 - Something went wrong in the connector. See the logs for more details.2022-08-23 15:22:05 e[43mdestinatione[0m > java.lang.Exception: Verification error(s) occurred for WRITE. Errors: [$.password: object found, string expected] 2022-08-23 15:22:05 e[43mdestinatione[0m > at io.airbyte.integrations.base.IntegrationRunner.validateConfig( ~[io.airbyte.airbyte-integrations.bases-base-java-0.40.0-alpha.jar:?]2022-08-23 15:22:05 e[43mdestinatione[0m > at io.airbyte.integrations.base.IntegrationRunner.runInternal( ~[io.airbyte.airbyte-integrations.bases-base-java-0.40.0-alpha.jar:?]2022-08-23 15:22:05 e[43mdestinatione[0m > at ~[io.airbyte.airbyte-integrations.bases-base-java-0.40.0-alpha.jar:?]2022-08-23 15:22:05 e[43mdestinatione[0m > at io.airbyte.integrations.destination.postgres.PostgresDestination.main( ~[io.airbyte.airbyte-integrations.connectors-destination-postgres-0.40.0-alpha.jar:?]

We recently changed from the community Helm chart to the official one, but blew away the persistant volume(s), so there shouldn’t be anything left from previous.

Airbyte version 0.40.3
Source Postgres: 1.0.7
Dest Postgres: 0.3.23

Dustin, can you go into Connector Setting for Source and Destination and see if each connector can be validated/checked again?