MySQL to Postgres Sync have started failing

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Ubuntu, Windows
  • Memory / Disk: 32Gb / 2 Tb
  • Deployment: Docker
  • Airbyte Version: 0.39.20-alpha upgraded to 0.40.12
  • Source name/version: MySQL : 1.0.13
  • Destination name/version: Postgres: 0.3.26
  • Description:

I have a MySQL server in the cloud which syncs everyday to a local on premise postgres instance.
My sync was running every 12 hrs for last 5 months or so before it started failing since Friday.
I went through the sync log, 1st line of log had this message

JSON schema validation failed.errors: $.tunnel_method: must be a constant value NO_TUNNEL

We use SSH Authentication with an authentication key, so I double checked if Airbyte is able to connect to the MySQL database, Then I checked if my connector is updated, It was.
I deleted the source and added the source + connections again but I was still getting the sync errors.

Log before updating Airbyte logs-354.txt (517.5 KB)

I decided to update the Airbyte instance, and to delete and add the source + connection again.
Well, I’m still getting sync failures. After the update this is the new error message

Failure Origin: source, Message: Something went wrong in the connector. See the logs for more details.

Line 676 of the log, throws out this error:

The main thread is exiting while children non-daemon threads from a connector are still active.
Ideally, this situation should not happen...
Please check with maintainers if the connector or library code should safely clean up its threads before quitting instead

Does anyone know what must be the cause of this? From this error message, it seems there is a problem with the MySQL connector. Should I downgrade to a specific version?

Log after Airbyte update (181.5 KB)

I managed to get this running by :

  • Reverting to a earlier version of MySQL connector and
  • cleaning up the disk space on the Ubuntu VM

One of those has worked and my Sync is working again

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hey @gaurang, thanks for your patience - I was out for the Thanksgiving weekend. Are you using OpenSSH by any chance? What was the previous MySQL connector version before updating? I know some users have had a problem with that, I see a PR here but for some reason it was not merged:

As an alternative to SSH you could use RSA keys.