Quickbooks won't sync more than once

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Linux/UNIX (EC2)
  • Memory / Disk: 64 gb
  • Deployment: Docker
  • Airbyte Version: 0.35.67
  • Source name/version: Quickbooks 0.1.5
  • Destination name/version: BigQuery 1.1.9
  • Step: The issue happens on the second sync after adding a new refresh token in the source settings.
  • Description: The refresh token expires after each use with the Quickbooks API, but the connector does not handle the renewed refresh token that is returned from the API. This issue was also discussed on this GitHub Issue, but no updates lately. This is a serious issue with not being able to sync Quickbooks on a schedule without manually adding a new refresh token after each sync. Does anyone else have this issue and is it being worked on? Or do I need to adjust my source settings somehow?

Hi, @jscottpolevault! Thank you for bringing this up, I am checking where this is on our roadmap and will get back to you shortly.

Just heard form the team: we are working on upgrading the Quickbooks connector from alpha to beta, and this is one of the issues that will be fixed in the upgrade. You can keep an eye out for updates here.

1 Like

Hi - any updates on the status of this connector? Thanks.

Hi ,
@jscottpolevault I am trying to setup the quickbooks source , I had setup a sandbox app in quickbooks and synced using airbyte but all the tables were empty , Can you help with this ?

So sorry Adnan. I never tested a sandbox app. I have a few businesses I had QBO access to, so I synced that data to play with.

-Jordan

Its the access token that times out, not the refresh token. The access token has a 60 minutes life cycle. If you set it ti sync every hour it should work fine. Obviously not Ideal

Well if that’s the case, then I feel pretty dumb for not thinking through that! Thanks!