Source mysql 2.0.24 non-json response during connection creation

  • Is this your first time deploying Airbyte?: Yes
  • OS Version / Instance: amazon Linux, AWS EC2
  • Memory / Disk: 4Gb / 120gb
  • Deployment: Are you using Docker or Kubernetes deployment? Docker
  • Airbyte Version: What version are you using now? 0.44
  • Source name/version: source-mysql 2.0.24
  • Destination name/version: destination-bigquery-denormalized 1.2.20 or any other one
  • Step: The issue is happening during the creation of a new connection
  • Description:

I’m trying to create a connection from Mysql to BigQuery.
The source connection works and it is correctly saved.
There aren’t issues on the network side.
From the EC2 machine, I tested the connection using telnet and nslookup (as described in the guide with this link: Risoluzione di problemi di connessione a un'istanza database di Amazon RDS | AWS re:Post) without a problem.

After choosing all the tables to replicate I receive the error “Error: non-json response” in the UI.

I’ve several defined connections with MySQL sources that write to BigQuery.
They continue working but the problem is the same if I try to change one of them adding/removing some of the tables.

Analyzing the error on the browser with the Google Developer Tool, I see:

// non json result
StoreProvider-8fb34e50.js:57 Error: non-json response
    at x6 (StoreProvider-8fb34e50.js:836:13410)
    at async Object.mutationFn (useConnectionHook-ed38461c.js:1:2574)
StoreProvider-8fb34e50.js:836     POST 403
fi @ StoreProvider-8fb34e50.js:836
N @ StoreProvider-8fb34e50.js:836
KL @ StoreProvider-8fb34e50.js:836
create @ useConnectionHook-ed38461c.js:1
(anonymous) @ useConnectionHook-ed38461c.js:1
fn @ StoreProvider-8fb34e50.js:57
f @ StoreProvider-8fb34e50.js:57
Bh @ StoreProvider-8fb34e50.js:57
t.executeMutation @ StoreProvider-8fb34e50.js:57
(anonymous) @ StoreProvider-8fb34e50.js:57
Promise.then (async)
t.execute @ StoreProvider-8fb34e50.js:57
n.mutate @ StoreProvider-8fb34e50.js:57
(anonymous) @ index-273c1981.js:17
(anonymous) @ StoreProvider-8fb34e50.js:929
(anonymous) @ StoreProvider-8fb34e50.js:929
(anonymous) @ StoreProvider-8fb34e50.js:929
Promise.then (async)
(anonymous) @ StoreProvider-8fb34e50.js:929
(anonymous) @ StoreProvider-8fb34e50.js:929
(anonymous) @ StoreProvider-8fb34e50.js:929
(anonymous) @ StoreProvider-8fb34e50.js:929
r0 @ index-293a369b.js:37
o0 @ index-293a369b.js:37
a0 @ index-293a369b.js:37
Sf @ index-293a369b.js:37
Vp @ index-293a369b.js:37
(anonymous) @ index-293a369b.js:37
wp @ index-293a369b.js:41
n0 @ index-293a369b.js:37
Wp @ index-293a369b.js:37
bl @ index-293a369b.js:37
xl @ index-293a369b.js:37
e.unstable_runWithPriority @ index-293a369b.js:26
Hn @ index-293a369b.js:37
_p @ index-293a369b.js:41
w0 @ index-293a369b.js:37
StoreProvider-8fb34e50.js:836 // non json result

I did not understand why I have the 403 error on POST

I tried to downgrade source-mysql 2.0.24 with the previous versions but the error is still there.
I tried to replicate it on a local airbyte with the same source and destination versions and credentials and it works without problem.

Please, can you suggest me some checks/logs to verify?
Did you manage something similar in the past?