Source MySQL - stuck at : "Queueing query for table", "Preparing query for table"

Hello everyone,

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: GCE : e2-highmem-8, Ubuntu
  • Memory / Disk: 64 Go
  • Deployment: Docker
  • Airbyte Version: 0.41.0 (Had same error in previous version)
  • Source : MySQL (Aurora)
  • Destination: BigQuery
  • Step: The sync is stuck at this moment :
2023-02-23 09:41:19 e[44msourcee[0m > Queueing query for table: my_table
2023-02-23 09:41:19 e[44msourcee[0m > Preparing query for table: my_table 
  • Description: I have a connector from MySQL to BigQuery that syncronizes a large table (80Go, 6M lines, 50k lines a day), in mode “Incremental | Append” based on a field : “created_at”.
    I can initialise the table without any problem but when, syncronizing again the source table to add new data, the connector get stucked at that step.

  • Investigation already done :
    → The memory and CPU of my machine is fine.
    → The same table is syncronized on a less heavy ‘staging’ database and it works perfectly, could it be the size of the table in ‘production’ causing the problem ?
    → The connector can be stuck multiple hours
    → I tried creating a connector exclusively for that table, and the result is the same

Would you have any hints on why this problems occurs, or where to look for solutions ?

Thanks !

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Update : I found the problem, the cursor_field was not indexed in production database, hence the infinite response time.

Hey @Asertu,

Thanks for making this post and for digging into it. Happy to hear you found a solution! Feel free to post more questions in the forums or raise issues on our Github.