Suddenly after two days some of the syncs are failing

  • is this your first time deploying Airbyte: No
  • OS Version / Instance: AWS EC2
  • Memory / Disk: 32Gb/50 GB
  • Deployment: Docker
  • Airbyte Version: 0.40.7
  • Airbyte Source name/version: MySQL(0.6.13)
  • Airbyte Destination name/version: BigQuery(1.2.1)
  • Source name/version: AWS Aurora MySQL Serverless v2 (Compatible with MySQL 8.0.23)
  • Destination name/version: Bigquery
  • Step: Create a connection from MySQL to BigQuery with Incremental | Deduped + History for tables and Full refresh | Overwrite for views. Replication method for source is: CDC
  • Description: Everything was OK and with 1-hour frequency MySQL was syncing to BigQuery and suddenly I see some of the connections failed. You can see the logs for the failed syncs below:

The first connection which has a failed sync:
logs-22447.txt (4.3 MB)

The second connection has a failed sync:
logs-22451.txt (6.1 MB)

The third connection has a failed sync for several hours:
Unfortunately, the size of the log is more than 8 MB and I cannot send a zip file on this forum, too.

You can see that for example for the third one it was syncing successfully and I don’t know what is happening suddenly.

Memory and Storage status right now:

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hi @arashlayeghi, thanks for your patience - we are at an offsite this week and getting to things a bit slower. I will look into this and hope to have some thoughts for you early next week.

Another suddenly failed logs in version 0.40.9

04e3d7e6_b345_4aaf_8bbe_a89b52b3426b_logs_25928_txt.txt (5.3 MB)

Could you try pasting the json key into the Service Account field of the destination settings again? It might be getting skipped. Another option might be that too much data is being synced, how many tables are you syncing?

When I reset the source and reset the data and sycn again the problem s vanished for some days and again occurs after a few days.

For example please see this error:

04e3d7e6_b345_4aaf_8bbe_a89b52b3426b_logs_27012_txt.txt (4.9 MB)

It’s totally weird that this sync suddenly failed after several hours of syncing.

04e3d7e6_b345_4aaf_8bbe_a89b52b3426b_logs_27403_txt.txt (28.5 KB)

Could you update both Airbyte and the connectors to the latest versions? I’m getting some more input form my team and we’re wondering if updating would fix your issues.

I updated Airbyte to 0.40.10 and MySQL and BigQuery connectors to the latest versions, but last night suddenly we face this error

04e3d7e6_b345_4aaf_8bbe_a89b52b3426b_logs_30588_txt.txt (4.4 MB)

Anyway, we are migrating to Fivetran since Airbyte has a lot of issues and not solving them.

I am really sorry to hear that you’ve decided to migrate to Fivetran.

I have been researching this and think I have finally cause the root of the issue: the error may be happening because when the schema discovery process happens, Airbyte tries to discover all present schemas. This may exceed the size limit of the catalog. Here is the related issue:

It looks like the MySQL source is still being worked on in this regard. If you are still interested in trying to find a solution, I’d suggest to split the tables up into several different syncs as you are syncing a large amount of data. Please let me know if you’d like to continue this discussion!