Table name on the destination (source Oracle)

Is this your first time deploying Airbyte: Yes.
OS Version / Instance: Debian / n1-standard-2
Memory / Disk: 40GB
Deployment: GCP
Airbyte Version: 0.35.59-alpha
Source name/version: Oracle
Destination name/version: MySQL
Step: Connection is working.
Description: I have configured my pipeline and the sync is working. When i put on the Destination namespace:
Mirror source structure, i dont see any tables on my MySQL. When i put destination default, i saww the below:

Hi @dimbou,
Could you please share your sync logs when you use the Mirror source structure options?
Could you also please upload a screenshot of your current connection configuration?

Thank you!

Hi @alafanechere and apologies for the late reply.

Kindly note that we have 2 open issues. The first one is the above with the name of tables and the second is inside of tables, i see my data in a list and like source structure.

Please find attached the requested screenshots and logs.

logs-107.txt (5.8 MB)

When i choose mirror source structure, i dont see any tables in my destination.

Hey @dimbou,
The logs show that the source namespace was defined as the following by the source connector:


Does the destination connector create a DANAOS schema in your MySQL destination?

Hello @alafanechere ,

I have placed the above schema on the source database, because without that did not recognize any tables in my source. When i enter the schema name i can see my tables, which i want to load.

On the MySQL connector i dont see anything. Is it possible to arrange a remote connection to my PC to see live the pipeline?

Further to above, please find attached 2 screenshots from the destination database after the sync.

Normally, i should have a database structure like the third attachment.

Thank you for the screenshot. In which MySQL schema does the _airbyte_raw_* tables get created? If you want to achieve something like you showcase in the last screenshot you can try to set danaos in the prefix field of your connection setting.

Hi @alafanechere.

I have tried to setup manually the prefix, but there is not any change. Kindly find below all the steps which I have followed:

  1. I have created my source database (Oracle DB) and i have put manually schemas DANAOS, because if i leave it empty, the system could recognize my tables.
  2. I have created my destination database (MySQL).
  3. Attached you will find the latest pipeline settings.

5. If i choose: Normalized tabular data, please find attached the error logs.
6. If i choose raw data: please find attached a screenshot.
logs-118.txt (6.1 MB)
logs-121.txt (5.8 MB)

The mirror option for some reason , i dont see any tables in my destination database. Can you please check and advise? Please advise if you are available to check together the pipeline settings.

hi @alafanechere ,

Can you please assist regarding the subject issue?

Dear All,

Can you please on my issue?

Hi @dimbou,
Which MySQL version are you using?
I found this error in your normalization logs that probably explain the absence of final tables:

You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '__dbt__CTE__danaos_companies_ab1

The SQL is generated by DBT, we are currently upgrading our Mysql DBT adapter to a newer version that could fix your problem if you are using a recent version of MySQL.

hello @alafanechere ,

I am using MySQL version 5.7 . Can you please advise when the update will be ready so i can test the normalization in my pipeline?

You can subscribe to the notification on the PR, you will receive an email when it’s merged :slight_smile:

Hi there from the Community Assistance team.
We’re letting you know about an issue we discovered with the back-end process we use to handle topics and responses on the forum. If you experienced a situation where you posted the last message in a topic that did not receive any further replies, please open a new topic to continue the discussion. In addition, if you’re having a problem and find a closed topic on the subject, go ahead and open a new topic on it and we’ll follow up with you. We apologize for the inconvenience, and appreciate your willingness to work with us to provide a supportive community.