Why does Netsuite Connector role require "FULL" access?

My question is related to documentation step 2.4. The instruction is to give the role “FULL” access to every available permission. Why is that a requirement? Shouldn’t “View” be sufficient and for only the assets that we desire to be synced?

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hey! Also replying here, just to keep things consistent :slight_smile: This connector is in alpha and really new, so without further research I can’t tell you why these permissions are needed. I can look into that, but I’d say a good place to look would be the changelog:

Maybe ping the contributor who made the initial release? I’m sure they had particular thoughts about the permission scope when putting this together!

Same doubt here! It seems like excessive permissions. @AGanier could you manage to set-up the connector succesfully? I am getting the following error:

HTTPError('401 Client Error: Unauthorized for url: https://<realm_id>.suitetalk.api.netsuite.com/services/rest/record/v1/customer?limit=1')


I am receiving the same error and have started a thread on the topic that I’ll update if I’m able to achieve resolution. Right now we are planning to see if upgrading to a more recent version of AirByte solves the error.

Andrea and Alonso, today Netsuite is an alpha connector which can have some bugs like using roles which aren’t quite required. Feel free to open a Github issue to discuss with connector team improves around this connector.