Connecting to AWS Postgres Errors

  • Is this your first time deploying Airbyte?: Yes
  • OS Version / Instance: Windows
  • Memory / Disk: you can use something like 4Gb / 1 Tb
  • Deployment: N/A?
  • Airbyte Version: What version are you using now?
  • Source name/version: Postgres 14
  • Destination name/version:
  • Step: Adding as a new destination/source
  • Description: I’m trying to add a Postgres database on AWS RDS and following your tutorial at Load Google Sheets data to PostgreSQL in AWS RDS | Airbyte. All goes well until trying to add the source. I get:

Configuration check failed

Unsecured connection not allowed. If no SSH Tunnel set up, please use one of the following SSL modes: require, verify-ca, verify-full

So, I try using require, and get:

Configuration check failed
Message: HikariPool-1 - Connection is not available, request timed out after 10001ms

There’s no mention of the SSL options in the guide, and kind of lost as to why an unsecured connection is not allowed in the first place? I can connect unsecured from terminal. Any idea what I can do?