Destination set up - s3 public bucket access denied

  • Is this your first time deploying Airbyte?: Yes
  • OS Version / Instance: MacOS / personal laptop
  • Memory / Disk: 16Gb / 512GB ← laptop spec
  • Deployment: docker compose up
  • Airbyte Version: 0.40.30
  • Source name/version: None
  • Destination name/version: S3 / 0.3.19
  • Step: Set up the Destination
  • Description:
    with or without aws long time access key ID(AKIAxxxxxx) & secret access key, public bucket access denied like below screen shot. Additionally my aws account have s3 full access.
  1. Without access key ID & secret access key

  2. With access key ID & secret access key

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hey @Scene, I am unable to replicate your issue - let’s look further into the configuration of your bucket. The secret access key and ID are required, could you try generating a new secret access key/id?

@natalyjazzviolin thanks for your reply
Unfortunately i generated a new secret aceess key/id, still can’t access(with or without insert access key/id)
I attached my s3 public bucket configuration screen-shot.
please check it :pray:

That’s bizarre, I’m looking into it!

I’m having similar issues - same error - the only difference is I’m trying to use Big Query as a destination with GCS Staging method. TRied connecting service account, set all the permissions, generated new HMAC key pair yet still the error persists :frowning:

EDIT: I’ve tested BigQuery destination setup with same connection (GCS) method on older server with Airbyte version 0.40.26 and it works. On the new server with latest Airbyte (0.40.30) it gives 403 error (same credentials, destination, connection, everything).

On the old server, BigQuery destination’s version is 1.2.9, on the new one, it is 1.2.13.

Error is: State code: AccessDenied; Message: Access denied. (Service: Amazon S3; Status Code: 403; Error Code: AccessDenied; Request ID: null; S3 Extended Request ID: null; Proxy: null)

@Scene, are you using an IAM role? If so, that’s currently not functional, but we have an issue open for it:

@Vanesa, could you please make a separate post and a GitHub issue? That would be really helpful to keep everything organized per connector :slight_smile:

1 Like

I’m using aws user account not using IAM role.
Addtionally, other source & target(mysql DB, local etc… ) works well.
So if u find another reason about s3 issue , please reply to me

Finally, I solved this issue.
I create new IAM user and give new policy for bucket.
But, I can’t understand when I give same policy to my aws account it doesn’t work