AWS EKS S3 destination Auth Error

  • Is this your first time deploying Airbyte?: Yes
  • OS Version / Instance: AWS/EKS/EC2 (amzn)
  • Memory / Disk: 8Gb / 1 Tb
  • Deployment: Kubernetes
  • Airbyte Version: Latest
  • Source name/version:
  • Destination name/version: S3/latest
  • Step: Creating s3 destination
  • Description: S3 destination Auth Error

I setup Airbyte on AWS EKS using Kustomization. And now I am setting s3 as destination and get this error on webapp
“Internal Server Error: The Access Key Id you provided does not exist in our records. (Service: S3, Status Code: 403, Request ID: 172…)”
I tried with/without AWS credentials but I get the same error. Any way to fix/troubleshoot it?

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
Best,
The Community Assistance Team

Hello Pramit, it’s been a while without an update from us. Are you still having problems or did you find a solution?