Google Analytics source loads NULL values in custom report

Hi there,

  • Is this your first time deploying Airbyte? Yes
  • OS Version / Instance: AWS EC2 t2 large
  • Deployment: Docker
  • Airbyte Version: 0.36.4-alpha
  • Source name/version: Google Analytics
  • Destination name/version: PostgreSQL
  • Step: the issue is happening during sync
  • Description: Does not pull any data at all.

I’m using the Service account key authentication.
I’m only trying to pull data from a custom report:

[{"name": "main_kpi","dimensions":["ga:date","ga:channelGrouping","ga:campaign","ga:landingPagePath","ga:medium","ga:source","ga:deviceCategory"], "metrics":["ga:sessions","ga:users","ga:goal4Completions","ga:goal9Completions","ga:goal11Completions","ga:goal12Completions","ga:goal13Completions","ga:goal16Completions","ga:goal17Completions","ga:goal20Completions"]}]

Data is written to my destination but some columns (metrics or dimensions) always have NULL values:

  • ga:channelGrouping
  • ga:deviceCategory
  • ga:landingPagePath
  • all ga:goalXXCompletions columns

I don’t see anything in the logs.

These dimensions / metrics exist according to Google’s documentation.

What’s weird is that it only concerns columns with several words… Is it case sensitive? Should I use an underscore instead of a capital letter?

I’m using Fivetran to replicate the exact same data and there is no NULL value.

Thanks for your help.

logs-34.txt (503.9 KB)

Hello Clemence, I ran our integration tests with the custom query and was able to get records for device category and landing page path. I think for my case the goals are 0 because we didn’t configured it.

I used the exact same query you posted here so should works. Could you try with less dimensions and metrics?

Hello Marco,
Sorry for the delay.
It seems to work with less dimensions and metrics… How is it possible? With 7 dimensions and 10 metrics, I’m not exceeding the API limits, am I ?
Thanks !

Not at all! I asked the team if we have a contact in Google to ask about it. See discussion here:

Thanks, but it seems like the github issue is concerning Google Ads data, while I’m having trouble with Google Analytics.

In addition, I’ve tried to pull the exact same data using the Query Explorer and I don’t get any NULL value. Same with Fivetran.
Is it possible that Airbyte’s connector is putting more limits than the API itself?

The same query you posted in the first topic? Do you mind posting some screenshots of query explorer results and data landed by the connector? This will help team identify the problem

Well, I don’t know what happened in the first place but after resetting the data, it now works fine…
Thanks !!

1 Like

Hi there from the Community Assistance team.
We’re letting you know about an issue we discovered with the back-end process we use to handle topics and responses on the forum. If you experienced a situation where you posted the last message in a topic that did not receive any further replies, please open a new topic to continue the discussion. In addition, if you’re having a problem and find a closed topic on the subject, go ahead and open a new topic on it and we’ll follow up with you. We apologize for the inconvenience, and appreciate your willingness to work with us to provide a supportive community.