Helm Chart From 0.45.1 --> 0.42.0 Causes template Error

  • Is this your first time deploying Airbyte?: No

  • Deployment: Kubernetes via Terraformed Helm Chart

  • Airbyte Version: 0.40.3

  • Description: Attempted to deploy to pickup the latest application version, and I noticed the underlying Helm chart went from 0.45.1 to 0.42.0, and it now seems that my ingress values are now causing issues on the deploy.

Error: template: airbyte/charts/webapp/templates/ingress.yaml:53:33: executing “airbyte/charts/webapp/templates/ingress.yaml” at <.Release.Name>: nil pointer evaluating interface {}.Name

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hi @DustyShap, sorry to hear you’re running into this error! I’m looking into it and hope to have some ideas on a fix soon!

Thanks @natalyjazzviolin ! Happy to pair or call on it, incase it could help!

The best thing to do is to use the official repo:
as linked in the docs:

Let me know if this helps!

I am using that official chart, and using the version released today (0.40.6), but still getting the same error.

I’ve opened a PR @natalyjazzviolin —> Update ingress template value by DustyShap · Pull Request #16931 · airbytehq/airbyte · GitHub

Some eyes on it would be great so we can use our Web UI!

Great, thanks for doing that! I see it’s been triaged. We are at an offsite this week, so I think you should expect movement on it starting next week.