Issue while using Octavia apply [airbyte connections]

  • Is this your first time deploying Airbyte?: No

  • OS Version / Instance: Ubuntu 22.04

  • Memory / Disk: 8 gb/ 128 GB

  • Deployment: Docker

  • Airbyte Version: 0.40.22

  • Source name/version: MYSQL

  • Destination name/version: PostGres

  • Step:
    Issue is happening while applying airbyte configuration data to create a connection using octavia-cli

  • Description:
    While creating airbyte connectors using octavia-cli, I’m able to create airbyte sources & airbyte destinations using octavia apply .
    but during creation of connections its raising issue , is there a updated octavia version , currently I’m using octavia :0.40.22.

once octavia apply used to upload data from local to airbyte this issue is coming in terminal:

airbyte_api_client.exceptions.ApiTypeError: Invalid type for variable ‘geography’. Required value type is Geography and passed type was str at [‘geography’]

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Can you downgrade the version for now? I created the issue
One possible version is 0.40.14.

@marcosmarxm I’ve tried this, do we need to maintain airbyte version to be same?

and also when I try to use octavia init with version 0.40.14 I’m getting this issue

Error: Could not reach your Airbyte instance, make sure the instance is up and running and network reachable: (401)
Reason: Unauthorized
HTTP response headers: HTTPHeaderDict({'Server': 'nginx/1.23.2', 'Date': 'Thu, 24 Nov 2022 07:51:06 GMT', 'Content-Type': 'text/html', 'Content-Length': '701', 'Connection': 'keep-alive', 'WWW-Authenticate': 'Basic realm="Welcome to Airbyte"', 'ETag': '"637c0f15-2bd"'})
HTTP response body: <html>
    <meta charset="utf-8" />
    <title>Airbyte - Access Denied</title>
    <h1>🐙 Nope.</h1>
    <h2><code>HTTP Error Code: 401</code></h2>

      This deployment of Airbyte is protected by HTTP Basic Authentication.
      Please refer to the <a href="">Airbyte docs</a> to learn more about:
              <li><a href="">the default username/password</a></li>
              <li><a href="">securing your Airbyte deployment</a> including turning off or changing the default username/password.</li>

You can update the .env to remove the password and user from basic auth. I don’t think Octavia supports the basic auth feature now.

I’ve updated the version to Octavia 0.40.18

curl -s -o- | bash
alias octavia="docker run -i --rm -v \$(pwd):/home/octavia-project --network host --env-file \${OCTAVIA_ENV_FILE} --user \$(id -u):\$(id -g) airbyte/octavia-cli:0.40.18"

and added these variables to .octavia file.

nano ~/.octavia

& used all octavia commands.

mkdir airbyte-configs-data && cd airbyte-configs-data
octavia init
octavia import all

and removed params from connections/configuration.yaml:

octavia apply


Just an FYI for the Airbyte team:
The Readme for Octavia says the Env Variable for --airbyte-username and --airbyte-password is AIRBYTE_URL.

They should be updated to show AIRBYTE_USERNAME and AIRBYTE_PASSWORD.