Issue with script not running


The user is facing an issue where the script immediately exits without performing any actions, even after updating the setup by removing .env and docker-compose.yaml files. The user has tried running the script in refresh mode (-r) but it still doesn’t work. The user has checked permissions and can run other commands successfully.


OK I’ve got something I’m stuck on that’s probably stupid simple. But won’t do anything, it always just immediately exits. I can put echo statements up top and they print. I was trying to update my setup, so removed .env and docker-compose.yaml, then tried to run the -r refresh mode to get new files. But it doesn’t do anything.

I can pull down the new docker-compose.yaml and .env from the raw repo. and docker-compose up seems to file up the stack. But I’m a bit baffled on what I’m missing here with the sh script. It has write permissions, and i can run it, but it refuses to do anything.

I guess it’s one of the “run away from anything a little bit scary” exit conditions but I’m not sure what changed in terms of env vars or a command failure.

Might be time to nuke it all and start again I guess.

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want
to access the original thread.

Join the conversation on Slack

["", "refresh-mode", "docker-compose.yaml", "env-vars", "permissions"]

You might also try the abctl-based method, which is where things are moving going forward (will eventually replace docker compose):

It’s worth noting that you can pass the same values.yaml config you would use in the Helm-based deployment method (this one doesn’t read .env).

This seems to work. Had to install go, add to path, download abctl, and run it, but I have it up now.