Kubernetes Upgrade Error / 0.33.11-alpha ----> to 0.38.0-alpha

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Ubuntu
  • Memory / Disk: 4Gb / 1 Tb
  • Deployment: Kubernetes ?
  • Airbyte Version: 0.33.11-alpha
  • Source name/version: 0.33.11-alpha
  • Destination name/version: 0.33.11-alpha
  • Step: Upgrade Airbyte
  • Description:

When upgrading Airbyte on Kubernetes,0.33.11-alpha ----> to 0.38.0-alpha, i get the following error:

2022-05-16 15:27:40 ERROR i.a.s.ServerApp(main):295 - Server failed
java.lang.IllegalArgumentException: ‘CONFIGS_DATABASE_MINIMUM_FLYWAY_MIGRATION_VERSION’ environment variable cannot be null
at com.google.common.base.Preconditions.checkArgument(Preconditions.java:220) ~[guava-31.0.1-jre.jar:?]
at io.airbyte.config.EnvConfigs.getEnsureEnv(EnvConfigs.java:904) ~[io.airbyte.airbyte-config-models-0.38.0-alpha.jar:?]
at io.airbyte.config.EnvConfigs.getConfigsDatabaseMinimumFlywayMigrationVersion(EnvConfigs.java:380) ~[io.airbyte.airbyte-config-models-0.38.0-alpha.jar:?]
at io.airbyte.server.ServerApp.assertDatabasesReady(ServerApp.java:149) ~[io.airbyte-airbyte-server-0.38.0-alpha.jar:?]
at io.airbyte.server.ServerApp.getServer(ServerApp.java:182) ~[io.airbyte-airbyte-server-0.38.0-alpha.jar:?]
at io.airbyte.server.ServerApp.main(ServerApp.java:291) [io.airbyte-airbyte-server-0.38.0-alpha.jar:?]

Hey,
Could you please set the CONFIGS_DATABASE_MINIMUM_FLYWAY_MIGRATION_VERSION environment variable to 0.35.15.001 and let me know if the error persists? I suggest the value of your environment variable matches what is now expected in >=0.38.0 .