PostgreSQL destination connection config

  • Is this your first time deploying Airbyte?: No (nearly my first)

  • OS Version / Instance: Docker compose on MacOS (amd64)

  • Memory / Disk: you can use something like 4Gb / 1 Tb

  • Deployment: Docker (Compose)

  • Airbyte Version: 0.36.8-alpha

  • Source name/version: Postgres/0.4.12

  • Destination name/version: Postgres/0.3.19

  • Step:
    Sync fails during the normalization phase with SSL SYSCALL error: EOF detected.

  • Description:
    This is a timeout related to network connection resets on idles connections in an AWS RDS environment. The resolution is TCP keepalive. This is typically configured client-side. I see no option in the UI, how can I provide the JDBC connection URL option in an Airbyte destination?

[EDIT: I just realized that the error I’m getting is coming from dbt (“normalization phase”, derp!), hence Python, not from JDBC. So, same question, but now it’s about modifying the dbt connection options for TCP keepalive.]

Hey you will find jdbc_url_params in the destination settings where you can add it

I wasn’t clear in my first post: I don’t see any field in the UI for jdbc_url_params, neither when creating the destination in the first place, nor when updating the settings after creation.

I do see a jdbc_url_params field in the initial destination settings screen for MySQL, so I think this is a specific omission from the Postgres destination, perhaps related to the version that I’m running (0.36.8-alpha, aka HEAD of master as of yesterday).

Aha! I didn’t see the jdbc_url_params in the UI because it hadn’t been added yet. But now it has! 🎉 Destination Postgres: Add jdbc_url_params input by noahkawasaki-airbyte · Pull Request #12195 · airbytehq/airbyte · GitHub