Destination PostgreSQL - verify-ca not correct fields listed & times out (non-ssl works fine)

  • Is this your first time deploying Airbyte?: Yes
  • OS Version / Instance: Ubuntu 22.04.1 LTS
  • Memory / Disk: you can use something like 8Gb / 20 Gb
  • Deployment: Docker Compose
  • Airbyte Version: What version are you using now? v0.40.23
  • Source name/version: PostgreSQL / 15
  • Destination name/version: PostgreSQL / 15
  • Step: creating the destination
  • Description:

When I try to enable SSL with verify-ca, I’m not seeing necessary fields like client cert and client key. I managed to fill these fields by switching to verify-full and adding a volume mount to /etc/hosts with the entry for my CloudSQL instance. However, now I’m seeing an nginx timeout when trying to connect. Like I said in the title: non-SSL works fine, so it isn’t network related.


Hey @hoffmanc, thanks for the post.

You mentioned that non-SSL connectivity works fine, so the issue is probably not related to the network.

To troubleshoot this issue further, can you check the following?:

  1. Verify that the SSL certificate and key are correctly configured and are located in the specified directories.
  2. Check the log files for the Airbyte application and the PostgreSQL server for any error messages that might provide more information about the issue.
  3. Make sure that the PostgreSQL server is configured to allow SSL connections and that the correct SSL mode is set.
  4. Try using a different SSL mode, such as require, to see if the issue is related to the verify-full mode.
  5. Check the network configuration and firewall settings to ensure that connections to the PostgreSQL server are not being blocked.

I hope this helps. Let me know if you have any additional questions or if you need further assistance.