Potgres sync fail after update 0.4.0 -> 1.0.2

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Docker image
  • Memory / Disk: you can use something like 4Gb / 1 Tb
  • Deployment: Kubernetes
  • Airbyte Version: 0.39.32-alpha
  • Source: Postgres (1.0.2)
  • Destination: Google Cloud Storage (GCS) (0.2.9)
  • Step: Sync
  • Description:

I have a connection between Postgres and GCS. Everything worked fine since several weeks with the 0.4.0 connector version.
Today I did upgrade to Postgres 1.0.2 version and the connection is now broken.

I got this error :

Caused by: java.time.format.DateTimeParseException: Text '0' could not be parsed at index 0

Any idea why it doesn’t work anymore and why the connector has this regression ?

Could you try to refresh the schema and try to sync again?

Sadly I got the same issue even after refreshing the schema

The text ‘0’ doesn’t look as a DateTime latest version of Postgres become more restricted with data types. Could you check the columns from the table to identify if they have correct DataTime values?

@marcosmarxm I found the table that generates this issue.

The thing is it happens only in incremental mode (I don’t get the issue in full refresh mode).
One column has a default value set as CURRENT_TIMESTAMP(0) and this is slightly different from other tables that have a default value set as CURRENT_TIMESTAMP
Could it be the root cause ?

@marcosmarxm i’m now experiencing this after MySQL source from 0.6.2 to 0.6.4

I think this PR is causing it: Mkhokh/8858 cursor fields for incremental update by mkhokh-33 · Pull Request #14356 · airbytehq/airbyte · GitHub

Confirmed when I revert back to 0.6.2 my syncs are working again

1 Like

Lucien this is issue was solved in Postgres version 1.0.4
See PR: https://github.com/airbytehq/airbyte/pull/15877

1 Like

(post to check update)