Schema Discovery Issue in Local Docker Environment vs. Airbyte Cloud

Summary

The user is facing a schema discovery failure in a local Docker environment when setting up a connector built using the Builder tool. However, the schema discovery succeeds when the connector is exported and imported into Airbyte cloud. The issue was discovered when trying to add new tables to an active production pipeline.


Question

I have a connector that I built using the Builder. If I build it in a local docker environment, the schema discovery fails during connector setup. I have tried this on multiple builds. If I export the connector and import it into Airbyte cloud then the schema discovery doesn’t fail. Any ideas on why it fails in local but succeeds in cloud? <@U01MMSDJGC9> <@U01AB6V6NMQ>

I have been using this connector for a few months in an active production pipeline. I discovered the issue when I tried to add some new tables, deployed the connector but can’t pull in the new tables because the schema won’t refresh.



This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want to access the original thread.

Join the conversation on Slack

["schema-discovery", "local-docker-environment", "builder", "connector-setup", "airbyte-cloud", "production-pipeline"]