Source BigQuery copies schema but no records

Note: there’s no tag for source-bigquery yet. Please add one

  • Is this your first time deploying Airbyte?: Yes
  • OS Version / Instance: Ubuntu
  • Memory / Disk: 1 Tb (I have – the data is ~1Gb)
  • Deployment: Docker
  • Airbyte Version: 0.35.65-alpha
  • Source name/version: BigQuery
  • Destination name/version: Postgres
  • Step: Sync
  • Description: Kicking off sync, it ‘succeeds’ but only the schema is copied – no records are copied.

I’ve tried different permutations of settings: both normalized and raw JSON and also ‘overwrite’ vs ‘append’ and none of them get records.

logs.txt (114.7 KB)

Hey @schuyler1d, I added the requested tag.
I can’t find any obvious reason from your logs.
Do you have records in the raw tables?
Do you mind trying a full refresh to check if the root cause could be around the cursor management?

No records are in the raw tables.
I tried a full refresh (and also starting completely from scratch) and neither fixed the issue.

Could you please try to upgrade the destination-postgres connector to 0.3.17 ?
Do you mind sharing the full logs, you truncated it for readability and I thank you for that effort :slight_smile: but maybe a small error line was overlooked :thinking:

It worked after the update! Thank you!

Hi there from the Community Assistance team.
We’re letting you know about an issue we discovered with the back-end process we use to handle topics and responses on the forum. If you experienced a situation where you posted the last message in a topic that did not receive any further replies, please open a new topic to continue the discussion. In addition, if you’re having a problem and find a closed topic on the subject, go ahead and open a new topic on it and we’ll follow up with you. We apologize for the inconvenience, and appreciate your willingness to work with us to provide a supportive community.