Spotless styling task failed on my local environment

OS: Ubuntu 22.04 LTS, 64-bit, gnome version - 42.2

I am trying to build locally with intellij idea, but gradle tasks failed:

    format 'styling', {
        target createSpotlessTarget(['**/*.yaml', '**/*.json'])


error log:

* Exception is:
com.intellij.openapi.externalSystem.model.ExternalSystemException: Could not create task ':spotlessStylingApply'.
Could not create task ':spotlessStyling'.
Can't automatically determine npm executable and none was specifically supplied!

Spotless tries to find your npm executable automatically. It looks for npm in the following places:
- An executable referenced by the java system property 'npm.exec' - if such a system property exists.
- The environment variable 'NVM_BIN' - if such an environment variable exists.
- The environment variable 'NVM_SYMLINK' - if such an environment variable exists.
- The environment variable 'NODE_PATH' - if such an environment variable exists.
- In your 'PATH' environment variable

If autodiscovery fails for your system, try to set one of the environment variables correctly or
try setting the system property 'npm.exec' in the build process to override autodiscovery.
	at org.jetbrains.plugins.gradle.model.ProjectImportAction.addBuildModels(

Hello @kananindzya, could you try these steps:

  1. File → Invalidate caches / Restart

  2. Shutdown Intellij Idea

  3. Remove .gradle folder in the user home directory

  4. Restart Intellij Idea let it download all the Gradle packages

Hi @natalyjazzviolin ,

Should I set some optional options?

Without these options the error is also reproduced

Looks like this is a problem with Intellij Idea, and not with Airbyte. Here is their documentation on Gradle, let me know if that helps you find the correct ocnfiguration:

May I know if this problem has been resolved? I am facing the same

This is a problem with the Spotless Gradle plugin, not with Airbyte. @fishleonghhh I suggest you double check your IDE and plugin configuration!

I had the same problem. Installing node using the installer and not through homebrew: Download | Node.js from aepsdk-edgeidentity-android/ at main · adobe/aepsdk-edgeidentity-android · GitHub works for me.

Thanks so much for your input, @Namig_Aliyev! @fishleonghhh @kananindzya could you check if this fix works for you?

Hi, for information, the solution proposed by @Namig_Aliyev worked for me :slight_smile: