Trouble setting up Salesforce as a source for OSS


User is facing issues setting up Salesforce as a source for OSS following Airbyte documentation. Errors include URI mismatch, typos, and being redirected to a login page with a missing code. User tried troubleshooting with Salesforce but no success. User does not have a SFDC admin currently.


I’m trying to set up Salesforce as a source for OSS and I’m having an issue getting the initial code following the instructions linked in the Airbyte docs. Has anyone successfully done this recently? I have the app set up already, I’ve gotten a few different errors from URI mismatch to typos to now being redirected to a login page saying there’s a missing code. I tried getting Salesforce to help troubleshoot but no luck there. I don’t have a SFDC admin currently so hoping to resolve this myself

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want
to access the original thread.

Join the conversation on Slack

["salesforce", "source", "oss", "airbyte-docs", "uri-mismatch", "typos", "login-page", "missing-code", "troubleshoot", "sfdc-admin"]

We use it for our clients pretty heavily (both with and without custom domains configured) . . . what’s the current error about a missing code?

Right now, I’m not getting any errors, it’s redirecting me to a login page but isn’t giving a code. Previously, I’ve gotten
URL No Longer Exists You have attempted to reach a URL that no longer exists on|
I’ve tried a bunch of different combinations of the url. This is what I’m trying right now with our client id removed:
<;client_id=>&lt;client_id&gt;&amp;redirect_uri=https%3A%2F%<|>%2F I’ve set the callback URL on the connected app to a few different options to see what works which have resulted in multiple different errors