Unable to compose up Airbyte - Database is not ready yet. Please wait a moment, it might still be initializing


I’m working with Airbyte for a couple of months and one day it just stopped working. When I start the app with docker-compose up, booting of the app is in the cycle of: Database is not ready yet. Please wait a moment, it might still be initializing… I checked to logs of DB and I can see that database system is ready to accept connections. But I also see a couple of db shutdowns before.

I already tried to pull the fresh version of Airbyte, and also completely delete all docker images and volumes, fully reinstall docker, and again pull the fresh and clean Airbyte version, without any additional changes, but it doesn’t help. The booting is still stuck in the cycle of Please wait a moment, it might still be initializing… I also tried to let the booting running for 4 hours, with no luck.

You can find logs attached to this message. Can you please help me to resolve this issue? Thanks.


worker.log (73.1 KB)
db.log (3.0 KB)

Hi @DavidSlaninka,
Could you share which version of Airbyte you are using?
Do you mind trying to install the latest one after deleting all Airbyte images and volumes?
Could you please also share the bootloader logs?
Did you edit some parameters in the .env file or in the docker-compose.yaml file itself?

Hi @alafanechere,

OS Version / Instance: Mac OS
Memory / Disk: 8Gb / 256Gb SSD
Deployment: Docker
Airbyte Version: 0.35.65-alpha

Today I have also deleted all Airbyte images and volumes and try to install the latest version v0.36.2-alpha, but this problem still presists.

I didn’t change anything in .env file or docker-compose.yaml. All I did was:

git clone https://github.com/airbytehq/airbyte.git
cd airbyte/
docker-compose up

Please find attached bootloader logs.

Hi @DavidSlaninka
You probably changed the value of CONFIG_DATABASE_USER and CONFIG_DATABASE_URL as CONFIG_DATABASE_URL targets the cloud database hosted in AWS.
If you want to use the same database for config and jobs I would suggest you to remove the CONFIG_DATABASE_* env variable and only set :

DATABASE_URL # translate manually DATABASE_URL=jdbc:postgresql://${DATABASE_HOST}:${DATABASE_PORT/${DATABASE_DB} (do not include the username or password here)

Hi there from the Community Assistance team.
We’re letting you know about an issue we discovered with the back-end process we use to handle topics and responses on the forum. If you experienced a situation where you posted the last message in a topic that did not receive any further replies, please open a new topic to continue the discussion. In addition, if you’re having a problem and find a closed topic on the subject, go ahead and open a new topic on it and we’ll follow up with you. We apologize for the inconvenience, and appreciate your willingness to work with us to provide a supportive community.