Unable to replicate Microsoft teams data on destination due to sync failure

Hi,
I have created a connection using following:
Source : Microsoft teams
Destination: 2 destinations ->Redshift & S3 bucket.

I have tried with multiple streams but recent streams I tried are :

  • groups
  • conversations
  • group members
    In case of all streams sync for connection is failing .However, empty tables corresponding to aforementioned streams are being created in destination.
    I tried with both normalization/non-normalization.

Logs are attached below :
logs.log (64.4 KB)

Hi @aqsa,
It looks like this might be a permissions issue on the source side. Did you follow this setup document when providing permissions to the Microsoft Graph API?
https://docs.airbyte.com/integrations/sources/microsoft-teams/#setup-guide

Hi @natalyjazzviolin ,
Yes we followed same document for setting up connector. Moreover , we did provide required permissions.
Thank you

I think we need to dig in deeper, I see the exception raised by the source is Authorization_IdentityNotFound","message":"The identity of the calling application could not be established.

I’ve found a stackoverflow thread that might be useful, could you double check that you are using the correct tenant ID as opposed to the ‘common’ string?
https://stackoverflow.com/questions/37151346/authorization-identitynotfound-error-while-accessing-graph-api

Hi @natalyjazzviolin We have tried with the users stream of MS teams, the connection is failing. We can get the “all users in the organization” in tenant of same account using the Microsoft Graph explorer. This implies that there is nothing incorrect with permissions of account or tenant ID.

We have also tested this with airbyte env version 0.40.6 but still sync was failing with “users” stream.

I see, then the issue must be somewhere else. Could you make sure everything is updated?