Upgrade to version 0.50.9 resulting in 502 Bad Gateway


User facing 502 Bad Gateway error after upgrading from version 0.44.3 to 0.50.9 when entering username and password on the UI.


Hi, I tried to upgrade 0.44.3 to 0.50.9 but I got 502 Bad Gateway after I entered username:airbyte and password:password on UI, does anyone can help me out?

This topic has been created from a Slack thread to give it more visibility.
It will be on Read-Only mode here. Click here if you want
to access the original thread.

Join the conversation on Slack

["upgrade", "502-bad-gateway", "version-0.44.3", "version-0.50.9", "username-airbyte", "password-password", "UI"]

You probably want to check the timeout settings (it sounds like you’re using the default nginx proxy that loads for basic auth with the docker compose install method, so you may want to increase BASIC_AUTH_PROXY_TIMEOUT in your .env

In some cases I’ve also seen JOBS_DATABASE_INITIALIZATION_TIMEOUT_MS and CONFIG_DATABASE_INITIALIZATION_TIMEOUT_MS when migrations/upgrades are involved

<@U035912NS77> I took a look at .env and BASIC_AUTH_PROXY_TIMEOUT=900 , what’s the number should I increase to?

How quickly does that error come out? if it’s less than 15 minutes, then it isn’t a timeout

<@U035912NS77> Yes, it comes out within few seconds and surprisingly now 502 is gone, but my new issue is Safari can’t open the page “localhost:8000”, can you please help me out?

I would check your docker logs and make sure everything came up correctly. could be that there’s an nginx error for the reverse proxy, or that there’s some issue with the server container

<@U035912NS77> please see attached logs, I can see there is an error about Micronaut, many thanks

<@U035912NS77> updates: Airbyte UI is live after I upgraded to 0.55.11, all issues i had have been resolved

Interesting, I’m wondering if this was either a bug in that version of if there was a difference in config options.

Out of curiosity, is there a specific connector or other reason you’re running an older version compared to jumping straight to 0.63.x?

<@U035912NS77> I tried to directly upgrade it to 0.62.3 yesterday, but I got bootloader issue and Marcos highly recommended to upgrade fewer versions

Gotcha, makes sense. Docs tend to be more reflective of more recent versions, so I was wondering if some of the issues may be from older configs against newer versions (which is a very common problem when upgrading all at once).

You’ll find that the most recent versions are much more likely to upgrade without any issues. So once you work through these things you probably won’t have nearly as many headaches in the future

<@U035912NS77> Good to know, thank you so much. I will jump to the latest version in the near future. I actually have one more question if you could provide any guide: I’ve deployed Airbyte on AWS EC2 and been opening 2 terminal windows to connect all the time, one is for Airbyte connection and one is for EC2 instance connection, is there a way to let both of them work in the background without the terminal?

If you’re using run-ab-platform.sh, you can pass the -b or --background to run docker compose up in detached mode (in the background). I believe the newer abctl version runs in the background by default.

Yes, I’m using run-ab-platform.sh -b , thanks a lot