Airbyte doesn't detect any tables from Postgres 14

  • Is this your first time deploying Airbyte?: No
  • OS Version / Instance: Debian 10
  • Memory / Disk: 4Gb / 25 Gb
  • Deployment: Docker on GCP VM (Compute Engine)
  • Airbyte Version: v0.35.65-alpha
  • Source name/version:
  • Destination name/version:
  • Step: Creating the connection with a new source (Postgres 14.0)
  • Description: I am trying to create a new connection between a GCP CloudSQL (Postgres) and BigQuery. When I set up the connection with all the correct credentials, host, etc…It’s working but it detects no tables. I’ve check the database manually with the same credentials and the tables are there with data. Have you any clue on what could go wrong ?

Thanks !

I had a similar issue last month. I rolled back the postgres connector to v0.4.4 and it worked for me. I tried to use the v0.4.10 connector a few hours ago and it sill didn’t work for me.

1 Like

It works ! Thanks.
Do we have to open a bug issue for this or is it already known ?

There is an issue open here: Schema fetch returning empty on postgres >= 0.4.5 · Issue #10548 · airbytehq/airbyte · GitHub