Custom Connector not showing after successfull import

  • Is this your first time deploying Airbyte?: Yes
  • OS Version / Instance: Linux(GCP compute engine) .
  • Memory / Disk: you can use something like 4Gb / 1 Tb
  • Deployment: Are you using Docker or Kubernetes deployment? Docker
  • Airbyte Version: What version are you using now? 0.39.5-alpha
  • Source name/version: Docker Hub
  • Step: Creating a new connector ?
  • Description:

Hi there !
I’m facing an issue while importing a new connector. I’m trying to import this connector.
The import seems to work properly (I don’t get any error) and in logs i got a 200 answer code. However the connector don’t show up in the list after refreshing the page (I tried with other docker image and same result).

Hi @alexisc,
I’m able to reproduce this bug using 0.39.5. I’m going to escalate this problem to our engineering team.

@alexisc I created this GitHub issue and escalated it internally. Please subscribe to the issue to receive updates. I’m closing this thread now as you will be updated on GitHub.

As a temporary workaround you can run the following SQL query on the airbyte database:
UPDATE actor_definition SET public = true WHERE name = 'connectorname';

1 Like

Thanks a lot @alafanechere for the quick feedback and workaround !