ERROR: Could not find a version that satisfies the requirement airbyte-cdk~=0.1.56

  • Is this your first time deploying Airbyte?: Yes
  • OS Version / Instance: WSL2 on Windows
  • Memory / Disk: 16Gb /
  • Deployment: Docker
  • Airbyte Version: airbyte-cdk~=0.1.56
  • Source name/version: excahngerate API
  • Destination name/version:

Hi all, I am a beginner trying to follow the tutorial for creating a connector for http API, and I am stuck, I cant install dependenncies for Airbyte CDK, can you please help me fix it :slight_smile: I get this error :

Obtaining file:///home/cber/airbyte/airbyte-integrations/bases/source-acceptance-test (from -r requirements.txt (line 1))
Obtaining file:///home/cber/airbyte/airbyte-integrations/connectors/source-python-http-example (from -r requirements.txt (line 2))
Collecting PyYAML~=5.4
  Using cached PyYAML-5.4.1-cp38-cp38-manylinux1_x86_64.whl (662 kB)
ERROR: Could not find a version that satisfies the requirement airbyte-cdk~=0.1.56 (from source-acceptance-test==0.0.0->-r requirements.txt (line 1)) (from versions: 0.1.0rc3, 0.1.0rc4, 0.1.0rc5, 0.1.1, 0.1.2, 0.1.3, 0.1.4, 0.1.5, 0.1.6rc1, 0.1.6, 0.1.7, 0.1.8, 0.1.9, 0.1.10, 0.1.11, 0.1.12, 0.1.13, 0.1.14, 0.1.15, 0.1.16, 0.1.17, 0.1.18, 0.1.20, 0.1.21, 0.1.22, 0.1.23, 0.1.24, 0.1.25, 0.1.26, 0.1.27, 0.1.28, 0.1.29, 0.1.30, 0.1.31, 0.1.32, 0.1.33, 0.1.34, 0.1.35, 0.1.36, 0.1.37, 0.1.38, 0.1.39, 0.1.41, 0.1.42, 0.1.43, 0.1.44, 0.1.45, 0.1.46, 0.1.47, 0.1.48, 0.1.49, 0.1.50, 0.1.52, 0.1.53)
ERROR: No matching distribution found for airbyte-cdk~=0.1.56 (from source-acceptance-test==0.0.0->-r requirements.txt (line 1))

Weird, https://pypi.org/project/airbyte-cdk/ the latest version of Airbyte CDK is 0.1.60 (2022-06-10) can you try to clean Python cache or maybe use 0.1.53 version as == in your setup?

Hi, my bad, I was not using the latest version of python, now itโ€™s all right.

Thank you for your reply.