No module named 'airbyte_cdk'

Hi! Im trying out the configuration based connector generation. Following the tutorial and got stuck on python spec. This is the error message:

(.venv) martin@Martins-MBP source-provet-cloud-api % python spec
Traceback (most recent call last):
  File "/Users/martin/Repositories/airbyte/airbyte-integrations/connectors/source-provet-cloud-api/", line 8, in <module>
    from airbyte_cdk.entrypoint import launch
ModuleNotFoundError: No module named 'airbyte_cdk'

I just ran a git pull and running Airbyte 0.40.15. My python version is 3.10.8 and working on a mac book.

I reran pip install -r requirements.txt.

Requirement already satisfied: airbyte-cdk~=0.2.0 in ./.venv/lib/python3.10/site-packages (from source-acceptance-test==0.0.0->-r requirements.txt (line 1)) (0.2.1)

Hello there! You are receiving this message because none of your fellow community members has stepped in to respond to your topic post. (If you are a community member and you are reading this response, feel free to jump in if you have the answer!) As a result, the Community Assistance Team has been made aware of this topic and will be investigating and responding as quickly as possible.
Some important considerations that will help your to get your issue solved faster:

  • It is best to use our topic creation template; if you haven’t yet, we recommend posting a followup with the requested information. With that information the team will be able to more quickly search for similar issues with connectors and the platform and troubleshoot more quickly your specific question or problem.
  • Make sure to upload the complete log file; a common investigation roadblock is that sometimes the error for the issue happens well before the problem is surfaced to the user, and so having the tail of the log is less useful than having the whole log to scan through.
  • Be as descriptive and specific as possible; when investigating it is extremely valuable to know what steps were taken to encounter the issue, what version of connector / platform / Java / Python / docker / k8s was used, etc. The more context supplied, the quicker the investigation can start on your topic and the faster we can drive towards an answer.
  • We in the Community Assistance Team are glad you’ve made yourself part of our community, and we’ll do our best to answer your questions and resolve the problems as quickly as possible. Expect to hear from a specific team member as soon as possible.

Thank you for your time and attention.
The Community Assistance Team

Hey @martindlarsson, thanks for your patience!
Just to make sure we are on the same page, is this the tutorial you’re following?

Yes @natalyjazzviolin

There might be something wrong with your Python path or configuration, this is likely not an issue with the connector generator. Could you double check that Python is in your path and you’re using the correct alias?

(.venv) martin@Martins-MBP source-provet-cloud-api % python --version
Python 3.10.8

Is that correct?

OK I managed to solve it. By running python3 spec it worked. Python versions is hard…

So glad you were able to solve it! And thank you for including the command in your update :slight_smile: