Unable to replicate data for some Gitlab streams to destination amazon S3

I am trying to replicate the data for projects & Project label from gitlab to Amazon S3 bucket but no data is being emitted from the source side although data exists in the gitlab.

Documentation for airbyte showing that the connector outputs streams project label

Project label existing in my gitlab

Selected the following streams for replication

Sync ran shows that no records are emitted or committed

Logs for the sync ran
logs-15468.txt (29.0 KB)

Hey @MahakUrooj,
I think this is might be related to this bug. Feel free to share that you are affected by this and upvote this issue. You can also try to fix it yourself if you feel comfortable with Python programming.

Hi @alafanechere,

My issue is a bit different from the above attached bug as my Project exist directly under the Group in Gitlab but still it is not picking up the data for the streams.

In my case, its not picking up any data from the project level. It is only replicating data that exist at the group level.

I have tried different scenarios listed below:
Project existing in a subgroup
Project existing in a group
Project existing directly in namespace (project doesn’t belong to any group).

In all the above mentioned scenarios, still data is not replicated for the project like project labels, members, milestones, issues, merge requests etc.

Hey @MahakUrooj,
Could you please share a screenshot of your Gitlab connector configuration (do not show the private token)?

I tried to reproduce the following scenario (running GitLab connector version 0.1.4). I was able to successfully run a sync of the projects stream and I do have Gitlab projects data written to my destination.

Maybe the error comes from your source configuration on the projects field, the connector requests to name the projects like <group_name>/<project-name>.

I took the URL encoded group and project name from a Gitlab URL:

Hey @alafanechere

please find the attached screenshot for gitlab connecor configurations

Right, this might be the issue as i am directly giving the project name instead of specifying the group name with it

Yes, please try with projects : cdpaas/cdpaas

HI @alafanechere,

My issue is resolved.
Thank you for your timely assistance, much appreciated.

Please let me know, how can i close this ticket and leave a feedback for you!

1 Like

Hi there from the Community Assistance team.
We’re letting you know about an issue we discovered with the back-end process we use to handle topics and responses on the forum. If you experienced a situation where you posted the last message in a topic that did not receive any further replies, please open a new topic to continue the discussion. In addition, if you’re having a problem and find a closed topic on the subject, go ahead and open a new topic on it and we’ll follow up with you. We apologize for the inconvenience, and appreciate your willingness to work with us to provide a supportive community.