Zendesk Support 0.2.3 errors out but 0.1.12 runs fine

  • Is this your first time deploying Airbyte: No
  • OS Version / Instance: EC2 t2.large
  • Memory / Disk: 16Gb
  • Deployment: Docker
  • Airbyte Version: 0.35.56-alpha
  • Source name/version: Zendesk Support 0.2.3
  • Destination name/version: Snowflake 0.4.24
  • Step: Sync fails
  • Description: I upgraded my Zendesk Support from 0.1.12 to 0.2.3 and now all of the jobs fail. Downgrading back to 0.1.12 works and the jobs finish. Not sure what’s happening, logs attached. Thank you for your help! I’ve been using this connector without fail for about 6 months now

logs-6110.txt (287.0 KB)

Hi @kyle-cheung,
Could you please double-check if your source configuration is filled properly? It’s possible that the configuration structure has changed a bit between 0.1.12 and 0.2.3 and that you need to update the fields accordingly.

Got it, let me try that!

Hey @alafanechere , I reset my source configuration, using API token and not oAuth but for some reason it’s still throwing the same oAuth error. See attached log and my setup page

logs-6403.txt (291.5 KB)

It looks like the source is still able to read records event if you’ve have this oauth related error at the end.
I think think the root cause of your problem is another error:

Traceback (most recent call last):
  File "/usr/local/lib/python3.7/site-packages/airbyte_cdk/sources/abstract_source.py", line 119, in read
    internal_config=internal_config,
  File "/usr/local/lib/python3.7/site-packages/airbyte_cdk/sources/abstract_source.py", line 159, in _read_stream
    for record in record_iterator:
  File "/usr/local/lib/python3.7/site-packages/airbyte_cdk/sources/abstract_source.py", line 215, in _read_incremental
    for record_counter, record_data in enumerate(records, start=1):
  File "/usr/local/lib/python3.7/site-packages/airbyte_cdk/sources/streams/http/http.py", line 354, in read_records
    params=self.request_params(stream_state=stream_state, stream_slice=stream_slice, next_page_token=next_page_token),
  File "/airbyte/integration_code/source_zendesk_support/streams.py", line 400, in request_params
    params = super().request_params(stream_state, next_page_token, **kwargs)
  File "/airbyte/integration_code/source_zendesk_support/streams.py", line 352, in request_params
    parsed_state = calendar.timegm(pendulum.parse(stream_state.get(self.cursor_field)).utctimetuple())
  File "/usr/local/lib/python3.7/site-packages/pendulum/parser.py", line 29, in parse
    return _parse(text, **options)
  File "/usr/local/lib/python3.7/site-packages/pendulum/parser.py", line 45, in _parse
    parsed = base_parse(text, **options)
  File "/usr/local/lib/python3.7/site-packages/pendulum/parsing/__init__.py", line 74, in parse
    return _normalize(_parse(text, **_options), **_options)
  File "/usr/local/lib/python3.7/site-packages/pendulum/parsing/__init__.py", line 115, in _parse
    return _parse_iso8601_interval(text)
  File "/usr/local/lib/python3.7/site-packages/pendulum/parsing/__init__.py", line 215, in _parse_iso8601_interval
    if "/" not in text:
TypeError: argument of type 'NoneType' is not iterable

It looks like a date field, used as a cursor field on one of the stream, is None and the connector expects it to be non nullable to perform a date parsing.

Could you please open an issue on our GitHub repo?

Submitted!

This is not running even with 0.1.12 now. A lot of our company OKRs use the Zendesk Support tables and these haven’t been able to run for the last 2-3 weeks. Are there any workarounds I could use?

logs-7023.txt (2.3 MB)

According to your latest log file on 0.1.12 it looks like you the type of some columns changed from DATE to TIMESTAMP (this is maybe related to the version downgrade). You will have to manually change the type of these columns on Snowflake or reset your destination data.

Snowflake error: 002108 (22000): SQL compilation error: cannot change column INITIALLY_ASSIGNED_AT from type DATE to TIMESTAMP_TZ(9)

These columns are in the following tables:

  • TICKET_METRICS_SCD
  • GROUP_MEMBERSHIPS

Hey @alafanechere , just tried resetting our destination data and resyncing. It attempted 3 times taking roughly 3 hours per run and still failed. Here are the logs. Thank you!

logs-7032.txt (6.6 MB)

@kyle-cheung did you manually deleted all the destination table too? I think there is a problem with the destination tables schema:
SQL compilation error: cannot change column INITIALLY_ASSIGNED_AT from type DATE to TIMESTAMP_TZ(9)

Did you delete the TICKET_METRICS_SCD table and re-run a sync or just deleted the rows?

I haven’t tried to delete the destination table, I’ll do that now and re-run.

This worked with 0.1.12!

Ok, I think it might be a migration issue during the upgrade between 0.1.12 and 0.2.3. As we have no migration process between version yet it’s possible that a schema change introduced in a recent version broke the normalization. Will you mind re-trying we the latest Zendesk Support version and delete the destination table beforehand?

I will try this this week and keep you posted