Singer connector dependencies conflict with Airbyte CDK

Hey folks,
I’m building a source-workday connector with airbyte cdk(python). When I’m installing the dependencies defined in setup.py

As the requirements.txt does not work well, i tried to install the dependencies individually, but it has this version conflict. Does anyone know how to install them properly? Thanks a ton!

Yes it’s possible to solve this check the code implementation for kustomer:
https://github.com/airbytehq/airbyte/blob/master/airbyte-integrations/connectors/source-kustomer-singer/setup.py